Setting up a SixXS Tunnel in Mikrotik

I haven’t seen any working examples of configuration for setting up a SixXS tunnel on a Mikrotik, so here’s on that I’ve put together.
I’ve just done this, and had to figure alot of it out for myself.

There are a few assumptions:
1) You have a static IP Address
2) You already have a SixXS account, which has been validated, etc.
3) You have a device running Mikrotik RouterOS.
4) You have the ipv6 package installed and enabled

So, onto the nitty gritty…

1. Apply for a tunnel, it _must_ be a static tunnel to your static IP

2. Leave your Mikrotik online, on that static IP, and wait for the SixXS staff to confirm that its reachable.

3. Once you’ve received your tunnel details, create a 6to4 tunnel.
/interface 6to4 add local-address= remote-address=
mtu=1280 name=SixXS-tunnel

Due to some bizarre naming mistake, the 6to4 in RouterOS isn’t actually a 6to4 gateway, its a 6in4 tunnel. But just do what I say here, and everything will work just fine…

4. Add your IPv6 address to your 6to4 interface.
/ipv6 address add address= interface=SixXS-tunnel

5. Add a route for all your IPv6 traffic, towards SixXS
/ipv6 route add dst-address=2000::/3 gateway=

Remember, the PoP IPv6 IP will be given to you in your email, but it will have a /64 on the end of it. Take the /64 out when you past it into the gateway.

6) Test a ping to your gateway
/ping

With any luck, you’ll get a reply from the gateway. If it doesn’t work, login the the SixXS website, and check that the PoP has actually configured your tunnel on their end.

7) If that works, try pinging something outside your linknet, like The Pirate Bay IPv6 tracker!

/ping 2a01:298:3:1::2

If that works, congratulations! You’re all working!

Now, depending on your ISK balance, you should request a subnet. And since I haven’t got enough ISK’s to request one, I have to leave my tunnel up for a week to earn another 5 ISK…
Then, I’ll post a howto on setting up a Subnet, and getting all your PCs on IPv6 too!

2 thoughts on “Setting up a SixXS Tunnel in Mikrotik”

  1. Hi,

    I´m just starting with IPv6 and received my RB750 yesterday.
    Mikrotik´s OS is something special, it seems. Do you have a basic firewall setting for a sixxs tunnel? So, first block everything, except keeping all necessary open for that tunnel?

    Michael

    1. Hi Michael,

      My Firewall rule for the Sixxs Tunnel, is to allow protocol 41 traffic from the endpoint IP.
      Eg:
      /ip firewall filter add action=accept chain=input comment=”6in4 Tunnel to HEANet” disabled=no protocol=41 src-address=193.1.31.74

      As you can see, HEANet is my tunnel broker, so you should change the src-address to match your tunnel broker.

      Regards,
      Kieran

Comments are closed.